Page 1 of 2

WRF EMS release 3.4.1

Posted: Mon May 20, 2013 6:22 pm
by oib
Maybe I should wait for the official announcement of the great and legendary Mr. Robert Rozumalski , but I could not resistI :D

I have noticed that since yesterday is online a new version of WRF EMS.

http://emsdata1.comet.ucar.edu/wrfems/releases/

Has this release something to do with the new NEWR/WRF EMS we are all impatiently waiting for some time?

It's possible to automate the upgrade process from an already installed version 3.x to v. 3.4.1 using the following command line?

% ems_install.pl --update

It is advisable to do the upgrade from EMS WRF 3.1 to EMS WRF 3.4 or it's better to do a fresh installation?

How to minimize the risk of corruption of the already existing version?

Bye

Re: WRF EMS release 3.4.1

Posted: Mon May 20, 2013 10:27 pm
by meteoadriatic
Hello,

This is nice to see!

I recommend that you wait official announcement, but if you are enough adventurous try it. I don't think that old install script will do installation correctly. But if not, you can always do manual installation (download and unpack files yourself), however, lot of things in configuration files will then need to be changed by you.

Re: WRF EMS release 3.4.1

Posted: Tue May 21, 2013 10:53 am
by oib
Thanks meteoadriatic!
I will wait for Robert to announce the new release and to provide to the community the new ems_install.pl script.

Re: WRF EMS release 3.4.1

Posted: Tue May 21, 2013 7:46 pm
by meteoadriatic
It is out :)

Re: WRF EMS release 3.4.1

Posted: Tue May 21, 2013 8:16 pm
by meteo60
Hi, i saw this great news: http://strc.comet.ucar.edu/software/newrems/

Has anyone tested the update? How to install it?

I register and i received an email with:
Hint: If you are installing a beta release please use:

% ems_install.pl --install <beta release version>

Another Hint: Run the following to avoid most errors:

% ems_install.pl --install 3.2.1.5.45.beta --nowkp

So I think it's necessary to wait for the last version?

Re: WRF EMS release 3.4.1

Posted: Tue May 21, 2013 9:35 pm
by meteoadriatic
meteo60 wrote:Hi, i saw this great news: http://strc.comet.ucar.edu/software/newrems/
So I think it's necessary to wait for the last version?
Hello, if you don't have last version installer you need to get it! Old can not do it, I'm pretty sure.

This is new (v3.4) installation script:
http://www.meteoadriatic.net/pub/wrf/ems_install.pl.gz

I hope it's OK to redistribute script here...

Re: WRF EMS release 3.4.1

Posted: Wed May 22, 2013 7:08 pm
by sky62
Today I successfully installed the new wrfems, no errors encountered during installation, however, after running the command dwiz to video out this alarm:

Use of uninitialized value $ENV{"STRC_UTIL"} in string at /usr1/wrfems/strc/ems_util/EMS_clean.pm line 22.
Empty compile time value given to use lib at /usr1/wrfems/strc/ems_util/EMS_clean.pm line 22
Use of uninitialized value $ENV{"STRC_UTIL"} in string at /usr1/wrfems/strc/ems_util/EMS_network.pm line 20.
Empty compile time value given to use lib at /usr1/wrfems/strc/ems_util/EMS_network.pm line 20
Undefined subroutine &main::exit called at dwiz line 47.

Thanks for the help

John

Re: WRF EMS release 3.4.1

Posted: Wed May 22, 2013 7:20 pm
by meteo60
Meteoadriatic you means that the script I received with the email is not for V3.4 but only for V3.2?
Where did you find this script? :shock: :D
And have you tested this script with ems_domain.pl --update ? Or must I do a complete install?

Re: WRF EMS release 3.4.1

Posted: Wed May 22, 2013 10:24 pm
by Canuck64
Just view ems_install.pl in any text editor. If it's new, it should have a date of 5/21/2013 and say version 3.4.1.

You cannot do an update from 3.1 or 3.2 to 3.4. Too much has changed

Re: WRF EMS release 3.4.1

Posted: Wed May 22, 2013 10:48 pm
by meteo60
I downloaded meteoadriatic's script and:
ems_install.pl --install 3.4.1.13.19 --import existing domain

all seem ok, just some change to do in some files to adapt them. I'm runing actually a new run to test it.