Wrf ems on Centos 6.0

Forum dedicated to older versions of EMS package (WRFEMS v3.2, v3.1 or older). Support is user-to-user based, so please help others if you can.
Post Reply
Antonix
Posts: 260
Joined: Fri Oct 16, 2009 8:53 am

Wrf ems on Centos 6.0

Post by Antonix » Thu Sep 08, 2011 5:40 pm

hello
during installation I got this text:

* Acquiring the WRF EMS package binaries

1 of 14 : EMS release.3.2.1.5.34.beta.allbin.x64.tbz -
Downloaded & Installed
2 of 14 : EMS release.3.2.1.5.34.beta.arwpost.x64.tbz -
Downloaded & Installed
3 of 14 : EMS release.3.2.1.5.34.beta.grads.x64.tbz -
Downloaded & Installed
4 of 14 : EMS release.3.2.1.5.34.beta.mpich2.x64.tbz -
Downloaded & Installed
5 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partA.x64.tbz - Downloaded &
Installed
6 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partB.x64.tbz - Downloaded &
Installed
7 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partC.x64.tbz - Downloaded &
Installed
8 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partD.x64.tbz - Downloaded &
Installed
9 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partE.x64.tbz - Downloaded &
Installed
10 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partF.x64.tbz - Downloaded &
Installed
11 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partG.x64.tbz - Downloaded &
Installed
12 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partH.x64.tbz - Downloaded &
Installed
13 of 14 : EMS release.3.2.1.5.34.beta.rip.x64.tbz -
Downloaded & Installed
14 of 14 : EMS release.3.2.1.5.34.beta.utilbin.x64.tbz -
Downloaded & Installed
Can't exec "/NMM/wrfems/util/bin/cpuid": No such file or directory at
./ems_install.pl line 2536, <> line 6.
Use of uninitialized value $cputype in substitution (s///) at
./ems_install.pl line 2541, <> line 6.
Use of uninitialized value $cputype in substitution (s///) at
./ems_install.pl line 2541, <> line 6.
Use of uninitialized value $cputype in substitution (s///) at
./ems_install.pl line 2541, <> line 6.


and when I do a simulation (also benchmarck) I get this error ...

[anto@Host-001 nmm]# ems_autorun
Can't locate Time/HiRes.pm in @INC (@INC contains:
/NMM/wrfems/strc/ems_util /NMM/wrfems/strc/ems_prep
/NMM/wrfems/strc/ems_auto /NMM/wrfems/strc/ems_run
/NMM/wrfems/strc/ems_post /NMM/wrfems/strc/ems_autorun
/usr/local/lib64/perl5 /usr/local/share/perl5
/usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl
/usr/lib64/perl5 /usr/share/perl5 .) at
/NMM/wrfems/strc/ems_prep/Prep_degrib.pm line 33.
BEGIN failed--compilation aborted at
/NMM/wrfems/strc/ems_prep/Prep_degrib.pm line 33.
Compilation failed in require at /NMM/wrfems/strc/ems_prep/Prep_main.pm line 27.
BEGIN failed--compilation aborted at
/NMM/wrfems/strc/ems_prep/Prep_main.pm line 27.
Compilation failed in require at /NMM/wrfems/strc/ems_auto/Auto_ems.pm line 30.
BEGIN failed--compilation aborted at
/NMM/wrfems/strc/ems_auto/Auto_ems.pm line 30.
Compilation failed in require at /NMM/wrfems/strc/ems_auto/Auto_main.pm line 94.
BEGIN failed--compilation aborted at
/NMM/wrfems/strc/ems_auto/Auto_main.pm line 94.
Compilation failed in require at ems_autorun line 35.
BEGIN failed--compilation aborted at ems_autorun line 35.
[anto@Host-001 nmm]#



according to your experience what would it be??

wrf_model
Posts: 55
Joined: Wed Feb 17, 2010 9:38 pm

Re: wrf ems on Centos 6.0

Post by wrf_model » Thu Sep 08, 2011 9:27 pm

Antonix wrote:hello
during installation I got this text:

* Acquiring the WRF EMS package binaries

1 of 14 : EMS release.3.2.1.5.34.beta.allbin.x64.tbz -
Downloaded & Installed
2 of 14 : EMS release.3.2.1.5.34.beta.arwpost.x64.tbz -
Downloaded & Installed
3 of 14 : EMS release.3.2.1.5.34.beta.grads.x64.tbz -
Downloaded & Installed
4 of 14 : EMS release.3.2.1.5.34.beta.mpich2.x64.tbz -
Downloaded & Installed
5 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partA.x64.tbz - Downloaded &
Installed
6 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partB.x64.tbz - Downloaded &
Installed
7 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partC.x64.tbz - Downloaded &
Installed
8 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partD.x64.tbz - Downloaded &
Installed
9 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partE.x64.tbz - Downloaded &
Installed
10 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partF.x64.tbz - Downloaded &
Installed
11 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partG.x64.tbz - Downloaded &
Installed
12 of 14 : EMS
release.3.2.1.5.34.beta.nawips.os.partH.x64.tbz - Downloaded &
Installed
13 of 14 : EMS release.3.2.1.5.34.beta.rip.x64.tbz -
Downloaded & Installed
14 of 14 : EMS release.3.2.1.5.34.beta.utilbin.x64.tbz -
Downloaded & Installed
Can't exec "/NMM/wrfems/util/bin/cpuid": No such file or directory at
./ems_install.pl line 2536, <> line 6.
Use of uninitialized value $cputype in substitution (s///) at
./ems_install.pl line 2541, <> line 6.
Use of uninitialized value $cputype in substitution (s///) at
./ems_install.pl line 2541, <> line 6.
Use of uninitialized value $cputype in substitution (s///) at
./ems_install.pl line 2541, <> line 6.


and when I do a simulation (also benchmarck) I get this error ...

[anto@Host-001 nmm]# ems_autorun
Can't locate Time/HiRes.pm in @INC (@INC contains:
/NMM/wrfems/strc/ems_util /NMM/wrfems/strc/ems_prep
/NMM/wrfems/strc/ems_auto /NMM/wrfems/strc/ems_run
/NMM/wrfems/strc/ems_post /NMM/wrfems/strc/ems_autorun
/usr/local/lib64/perl5 /usr/local/share/perl5
/usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl
/usr/lib64/perl5 /usr/share/perl5 .) at
/NMM/wrfems/strc/ems_prep/Prep_degrib.pm line 33.
BEGIN failed--compilation aborted at
/NMM/wrfems/strc/ems_prep/Prep_degrib.pm line 33.
Compilation failed in require at /NMM/wrfems/strc/ems_prep/Prep_main.pm line 27.
BEGIN failed--compilation aborted at
/NMM/wrfems/strc/ems_prep/Prep_main.pm line 27.
Compilation failed in require at /NMM/wrfems/strc/ems_auto/Auto_ems.pm line 30.
BEGIN failed--compilation aborted at
/NMM/wrfems/strc/ems_auto/Auto_ems.pm line 30.
Compilation failed in require at /NMM/wrfems/strc/ems_auto/Auto_main.pm line 94.
BEGIN failed--compilation aborted at
/NMM/wrfems/strc/ems_auto/Auto_main.pm line 94.
Compilation failed in require at ems_autorun line 35.
BEGIN failed--compilation aborted at ems_autorun line 35.
[anto@Host-001 nmm]#



according to your experience what would it be??
You can try it:

yum install perl-Time-HiRes

Antonix
Posts: 260
Joined: Fri Oct 16, 2009 8:53 am

Re: wrf ems on Centos 6.0

Post by Antonix » Thu Sep 08, 2011 9:34 pm

Wauuu!!!
;) :twisted:

Post Reply